Download Speed Issue
Incident Report for MyRepublicNZ
Resolved
On 01/01/2017, some MyRepublic customers in the south island were affected by slow speeds . Our technical team have identified the cause, a data handover had been causing the issue which has now been rectified and all services have now been restored.

If you are still experiencing issues with accessing the MyRepublic services, please reboot your router or modem.

We would like to thank you for your patience during this time and apologise for any inconvenience caused.
Posted Jan 03, 2017 - 16:30 NZDT
Identified
Some customers may be experiencing an issue with slow speeds on our Ultra speed connections. Our engineers are aware of this issues and are working with our providers to restore services as soon as possible. Please refer to our network status page for updates.
Posted Jan 02, 2017 - 10:48 NZDT
Investigating
We're investigating an issue with slow Fibre broadband service affecting some customers. We will provide an update once our engineers have identified any issue. Please refer to our network status page for updates.
Posted Jan 01, 2017 - 17:57 NZDT