Payment Issues
Incident Report for MyRepublicNZ
Resolved
This incident has been resolved.
Posted Oct 10, 2019 - 15:26 NZDT
Investigating
We are currently experiencing issues with our Billing System. Payments can't be processed from saved cards. If you are trying to pay through "PayNow" try the following link: https://bit.ly/2M4iZcd. We apologise for any inconvenience this may have caused.
Posted Oct 10, 2019 - 09:15 NZDT